歡迎您光臨本站 註冊首頁

UBUNTU eclipse必須是 jdk5.0以上

←手機掃碼閱讀     火星人 @ 2014-03-26 , reply:0

Ubuntu7.10(gutsy),在安裝eclipse時出現問題。

安裝eclipse,源中的版本是3.2

#sudo apt-get install eclipse

安裝java環境

#sudo apt-get install j2sdk1.4

打開eclipse時出現如下錯誤:

JVM terminated. Exit code=1(注:2G以上內存也容易出現這個錯誤代碼)
/usr/lib/j2se/1.4/bin/java
-Djava.library.path=/usr/lib/jni
-Dgnu.gcj.precompiled.db.path=/var/lib/gcj-4.2/classmap.db
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dosgi.locking=none
-jar /usr/lib/eclipse/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/lib/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 178012
-install /usr/lib/eclipse
-vm /usr/lib/j2se/1.4/bin/java
-vmargs
-Djava.library.path=/usr/lib/jni
-Dgnu.gcj.precompiled.db.path=/var/lib/gcj-4.2/classmap.db
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dosgi.locking=none
-jar /usr/lib/eclipse/startup.jar

搜了一下,網上說是VM的設置問題,修改eclipse.ini,加入-vm /usr/lib/j2se/bin/java(java目錄),我修改後還是出現同樣的錯誤。在命令行中運行eclipse可以看到eclipse能正確找到vm的所在。按照錯誤提示,建立了一個新文件

#touch /usr/local/lib/eclipse/.eclipseextension

#chmod 2775 /usr/local/lib/eclipse/.eclipseextension

#chown root:staff /usr/local/lib/eclipse/.eclipseextension

又出現新的錯誤

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/eclipse/core/launcher/Main (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

原來是java版本的問題,Unsupported major.minor version 49.0(48,49是Java編譯器內部的版本號,48表示是用JDK1.4來編譯運行程序的,49表示是用JDK1.5編譯運行程序的)。

刪除jdk1.4,安裝1.5

#sudo apt-get install sun-java5-jdk

再打開eclipse,沒有問題了

[火星人 ] UBUNTU eclipse必須是 jdk5.0以上已經有751次圍觀

http://coctec.com/docs/linux/show-post-180101.html