歡迎您光臨本站 註冊首頁

求助:RHCS+samba+AD域雙機切換遇到問題

←手機掃碼閱讀     火星人 @ 2014-03-04 , reply:0

求助:RHCS+samba+AD域雙機切換遇到問題

跑在節點1上,samba能正常訪問,此時虛擬ip能ping通;poweroff節點1,clustat查看雙機切換到節點2上面,此時不能訪問samba資源,提示「檢查名字拼寫時是否正常」(此問題可能是由於雙機切換smb服務雖然隨著虛擬ip飄移呢過正常啟動,但未能將主機加入域中導致)。
同時在節點2看到如下報錯:
Nov  1 16:20:04 mnas1 smbd:   kerberos_kinit_password [email protected] failed: Client not found in Kerberos database (使用kinit驗證能通過,不知道為何報這樣的錯誤)
Nov  1 16:20:04 m1 smbd: printing/nt_printing.c:nt_printing_init(659)
Nov  1 16:20:04 m1 smbd:   nt_printing_init: error checking published printers: WERR_ACCESS_DENIED
Nov  1 16:20:04 m1 smbd: lib/util_sock.c:open_socket_in(822)
Nov  1 16:20:04 m1 smbd:   bind failed on port 445 socket_addr = 192.168.0.4.
Nov  1 16:20:04 m1 smbd:   Error = Address already in use

我的hosts配置
192.168.0.2     m1   (bond0)
192.168.0.3     m2
192.168.0.4     vm(虛擬ip)

cluster.conf配置:
<?xml version="1.0"?>
<cluster config_version="5" name="smb_cluster">
        <fence_daemon post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="192.168.0.2 " nodeid="1" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="smb" nodename="192.168.0.2 "/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="192.168.0.3" nodeid="2" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="smb" nodename="192.168.0.3"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1" two_node="1"/>
        <fencedevices>
                <fencedevice agent="fence_manual" name="smb"/>
        </fencedevices>
        <rm>
                <failoverdomains>
                        <failoverdomain name="smb_ha" ordered="0" restricted="1">
                                <failoverdomainnode name="192.168.0.2" priority="1"/>
                                <failoverdomainnode name="192.168.0.3" priority="1"/>
                        </failoverdomain>
                </failoverdomains>
                <resources>
                        <ip address="192.168.0.4/24" monitor_link="1"/>
                        <smb name="smb" workgroup="TEST"/>
                </resources>
                <service autostart="1" domain="smb_ha" name="smb_services">
                        <ip ref="192.168.0.4/24">
                                <smb ref="smb"/>  (samba服務依附於虛擬ip服務,在smb其中腳本中添加加入、退出域語句,)
                        </ip>
                </service>
        </rm>
</cluster>


小弟在這裡先謝謝各位大神了,急求解啊!!!!
《解決方案》

求幫助啊!!
《解決方案》

這樣做可能不行吧? 除非你的兩台機器上的 samba使用同一個SID.

否則AD可能會認為你的機器換了一個IP上來, 但機器並沒有加到域里吧?
《解決方案》

那可以將2台設備的SID修改為一致的么?
今天還在驗證雙機,感覺還是有問題。
求詳解啊
謝謝啦
回復 3# q1208c


   
《解決方案》

回復 4# bksaih3

我也沒修改過. 因為我從來沒去搞過 samba 的HA. 原因很簡單, 在Windows系統中, HA 用的不多.

:em06:
《解決方案》

回復 5# q1208c


已經解決了,謝謝了哈。


   
《解決方案》

回復 6# bksaih3

噢, 那就好.

你最好把如何解決的也說明一下, 這樣其他碰到同樣問題的人就會少走彎路. :em02:
   

[火星人 ] 求助:RHCS+samba+AD域雙機切換遇到問題已經有772次圍觀

http://coctec.com/docs/service/show-post-4292.html