歡迎您光臨本站 註冊首頁

cluster中fence failed的問題

←手機掃碼閱讀     火星人 @ 2014-03-04 , reply:0

cluster中fence failed的問題

有兩台centos5.5機器,內核升級到2.6.28,在這兩個系統中安裝配置cluster,cluster.conf
配置文件如下:
<?xml version="1.0"?>
<cluster alias="gfscluster" config_version="5" name="gfscluster">
        <fence_daemon post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="server01" nodeid="1" votes="1">
                        <fence/>
                </clusternode>
                <clusternode name="server02" nodeid="2" votes="1">
                        <fence/>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1" two_node="1"/>
        <fencedevices>
                <fencedevice agent="fence_xvm" name="xenfence"/>
        </fencedevices>
        <rm>
                <failoverdomains/>
                <resources>
                        <clusterfs device="/dev/gfsvg/gfslv" force_unmount="0" fsid="55880" fstype="gfs2" mountpoint="/gfs" name="res" options=""/>
                </resources>
        </rm>
</cluster>

以前在內核2.6.28中這麼做過,沒有問題,現在/etc/init.d/cman start,啟動過程中,
Starting cluster:
   Loading modules... done
   Mounting configfs... done
   Starting ccsd... done
   Starting cman... done
   Starting daemons... done
   Starting fencing...           
前面都可以,到starting  fencing這塊就停止了,一直停留在這,查看message,提示另一個節點掛接failed,ccs_test connect  顯示連接成功,ccs_tool lsnode,顯示兩個節點,fencetype欄位處為空,以前做的時候也是空,不知道是什麼原因了,有知道的老師們給指點一下吧
《解決方案》

/etc/hosts文件也配置了,
127.0.0.1   localhost.localdomain   localhost
192.168.0.21   server01
192.168.0.22   server02

IP地址為心跳連接的地址,用另一塊網卡地址時,曾經連接上過,這也讓我很 迷惑
《解決方案》

怎麼沒人給我解答下啊
《解決方案》

:outu:
《解決方案》

我配置測試gfs存儲集群也遇到這個問題了,糾結~
《解決方案》

你配備了fence 這個設備嗎?  如果沒有這種設備, 失敗是沒關係的

真機沒玩過, 在虛擬機上碰上過這種情況, 啟動失敗不影響集群.  

期待高手解答
《解決方案》

你的fence 配置有問題吧

[火星人 ] cluster中fence failed的問題已經有706次圍觀

http://coctec.com/docs/service/show-post-4474.html