歡迎您光臨本站 註冊首頁

《redflag-Linux4.1操作系統初級教程》(5)郭守華 宋雪嬌

←手機掃碼閱讀     火星人 @ 2014-03-09 , reply:0
原文作者:
文章出處:
音量控制
所有的多媒體應用程序都可能涉及的聲音的播放以及混音,學習利用系統托盤中的音量控制來控制聲
卡的各個聲道是很有用的.要控制各個聲道,可以用滑鼠右鍵單擊系統托盤中的音量控制,然後選擇顯示
混音器窗口.如果音量控制不在系統托盤中, 可以從開始菜單啟動它:
【開始】→【應用程序】→【多媒體】→【音量控制】

圖5-1 音量控制
音量控制程序本質上是一個控制雙聲道音效卡 聲音的音頻混合器.如圖所示,對於各聲道,其主要部件
就是「衰減器」,用一個控制滑塊表示.衰減器控制了該聲道的音量.另外每個聲道都有一個靜音、錄音
和鎖定按鈕.靜音按鈕可以使該聲道靜音.鎖定按鈕可以將左右聲道鎖定到一起,在調節衰減器時,二者
將同步調節. 錄音按鈕用來打開或關閉音效卡上具有錄音功能的聲道.
可以用滑鼠拖動音量衰減器上的滑塊,來調節相應聲道的音量大小.
媒體播放
可以使用「多媒體播放器」播放CD、VCD、DVD以及各種格式的多媒體文件.
從開始菜單啟動多媒體播放器的方法是:
【開始】→【應用程序】→【多媒體】→【多媒體播放器】
多媒體播放器是一個基於xine的媒體播放軟體,可以播放CD、VCD、DVD光碟,也可以播放
avi/mov/wmv/mp3等格式的多媒體文件,也支持在線播放網際網路上的多媒體文件.
播放CD
要播放一個音頻CD,可以先把CD光碟放入光碟機然後啟動多媒體播放器.
播放前,應確保打開了揚聲器,否則是聽不到聲音的.
然後點擊菜單【播放】→【CD】就可以了.


多媒體播放器窗口下方的按鈕與普通 CD 播放機的按鈕樣子相同,功能也相同.可以通過這些按鈕來
控制CD的播放.可以調節音量大小、向前或向後跳轉、播放和暫停、停止、彈出光碟,以及通過下拉列
表跳轉到特定的音軌.
播放VCD 和DVD
要播放一個VCD,可以先把VCD光碟放入光碟機然後啟動多媒體播放器,點擊菜單【播放】
→【VCD】就可以了.
同理可以播放DVD.
視頻畫面的大小可以通過【查看】菜單加以控制.比如切換到全屏.
在全屏幕顯示的情況下,點滑鼠右鍵就會看到全部的菜單,仍然可以方便地進行各種操作.
播放媒體文件
可以使用多媒體播放器播放各種格式的多媒體文件.
如果要播放本地硬碟的文件,可以點擊菜單【文件】→【打開】,在彈出的對話框中選擇要播放的文
件就可以了.如果要選擇多個文件,可以按下鍵.
如果要播放網際網路上的文件,可以點擊菜單【文件】→【打開URL】,在彈出的對話框中輸入該文件
的網址就可以.
RM文件
可以使用系統自帶的RealPlayer來播放rm格式的媒體文件.
可以通過開始菜單啟動RealPlayer,具體方法如下,
【開始】→【應用程序】→【多媒體】→【RealPlayer】
直接雙擊.rm的文件,也可以自動啟動RealPlayer進行播放.
FLASH動畫
對於.swf格式的FLASH動畫,可以使用瀏覽器進行播放.從瀏覽器的【文件】菜單,選【打開文件】,
在文件打開窗口中找到相應的.swf文件,打開即可.
對於.exe格式的FLASH動畫,系統會把它當作一個DOS可執行文件出來.雙擊這種文件,系統會自
動啟動內嵌的wine,支持其運行.


錄製和編輯音頻
2
系統沒有自帶音頻的錄製和編輯工具,但是可以安裝Sweep軟體來滿足這方面的需要.圖5-6是
Sweep的主窗口界面.利用該軟體可以完成音頻的錄製、編輯、播放.在需要以特定格式存儲音頻時,可
以使用軟體的「另存為」功能,指定存儲格式就可以.創建新音頻文件
當sweep被啟動時,首先會出現圖5-7所示的對話框,詢問是要創建一個新文件,還是要打開一個現
有的文件.如果要創建一個新文件,可以單擊「Create new file」.
圖5-7
圖5-8
圖5-8的是創建新文件的對話窗口.通過該對話窗可以設定新文件的名字(Name,將來保存文件時,
還有機會設定該文件名並可以指定保存位置.因此此時可以暫時用默認的名字),時間長度(Duration),還可
以選擇抽樣率(Sampling rate).聲道(Channels)方面,如果是單聲道的,可以選mono,如果是雙聲道,可以
選stereo.對這些參數做出規定后,程序會自動計算出文件大小,並顯示在窗口下方(Data memory).
各參數確定無誤后,單擊「Create 」就會創建一個文件.如果想放棄,可以單擊「Don't create」.
如果程序已經啟動,那麼通過主窗口上的菜單操作,同樣可以創建一個新文件.方法是:
【File】→【New...】
另外,按快捷鍵 同樣可以創建一個新文件.
錄音
創建新文件后,就會出現主窗口.先執行菜單操作【Select】→【All】,然後單擊主窗口左下角的紅
點按鈕 就會出現錄音控制窗口如圖5-9.再單擊該窗口上帶紅點的按鈕 ,就開始錄音了.錄
音過程中,錄音控制窗口下方的狀態條會出現紅色閃爍條.另外,隨時可以按下帶白色方塊的按鈕 ,


停止錄音.
圖5-9
錄音后,應注意點擊「保存」按鈕進行保存,對應的菜單操作則是:
【File】→【Save】
新創建的文件,首次保存時,會出現保存對話框,在這個窗口可以確定文件的保存位置,保存的格式,
在此時應確定正式的文件名.
打開音頻文件
當sweep被啟動時,首先會出現圖5-7所示的對話框,詢問是要創建一個新文件,還是要打開一個現
有的文件.如果要打開一個新文件,可以單擊「Open existing file」.
圖5-10的是打開現有文件的對話窗口.通過該對話窗找到要打開的文件,選中它,然後單擊「確
定」按鈕,就可以打開該文件了.
如果程序已經啟動,那麼通過主窗口上的菜單操作,同樣可以打開一個現有的文件.方法是:
【File】→【Open...】
當然,按快捷鍵 同樣可以打開一個新文件.
編輯音頻文件
打開一個音頻文件后,可以選定某段音頻信號,進行複製(Copy)、粘貼(Paste)等操作.也可以進行清除
(Clear)和刪除(Delete)操作.清除操作是把選定的音頻段變成靜音,時間長度並不變.而刪除操作是把該段
音頻從文件中刪除,時間長度將縮短.
編輯操作主要涉及【Select】和【Edit】兩個菜單的使用.
文件格式轉換
Sweep支持多種音頻文件格式.默認使用aiff格式.
值得一提的是,MP3格式是受專利保護的,不能用於自由軟體.作為一種替代,可以使用OggVorbis
格式,該格式的質量是非常不錯的,也可以被各種播放軟體所支持.
打開要進行格式轉換的音頻文件,然後執行菜單操作【File】→【Save as...】,在保存文件的對話框中
指定新文件的存儲格式,即可實現文件格式轉換.


圖片瀏覽
在很多時候,都需要以各種不同的方式來查看圖片.有時需要看原有尺寸的圖片,有時則需要看大量
圖片的縮略圖.另外,還經常需要用簡單的工具管理圖片,比如對他們進行歸類,以便方便地找到需要的
文件進行瀏覽.下面來看一下圖片管理工具Gwenview的使用方法.
可以用Gwenview圖片查看器查看和組織圖片.要啟動該應用程序,可以從開始菜單執行如下操作.
【開始】→【應用程序】→【圖像】→【圖片瀏覽】
瀏覽圖片
啟動Gwenview打開存儲圖片的文件夾后,該應用程序就會生成給文件夾中保存的圖片文件的縮略圖.
要想查看某個圖片,只需用滑鼠雙擊相應的縮略圖,該圖片就會全屏顯示出來.可以使用縮放功能放到或
縮小圖片.在全屏顯示的情況下,可以單擊「退出全屏模式」按鈕退回到縮略圖模式.簡單地選中某個縮
略圖,會在預覽區預覽圖片.
Gwenview有一項非常有用的功能,那就是幻燈片.啟動該功能,將在全屏幕以幻燈片的形式顯示文
件夾中的圖片.
旋轉
可以使用 Gwenview 對圖片進行旋轉操作.支持的旋轉方式有順時針旋轉、逆時針旋轉、左右鏡像、
上下翻轉. 要執行這些功能,從【編輯】菜單中選擇相應的菜單項即可.
格式轉換
可以利用格式轉換功能,把圖片從一種文件格式轉換成另外一種文件格式.
Gwenview支持的文件格式有:
* Portable Network Graphics (PNG)
* Joint Photographic Experts Group (JPEG, JPG)
* Tag Image File Format (TIFF)
* TARGA format (TGA)
進行格式轉換的操作方法是:
【文件】→【另存為】
然後選擇相應的文件格式,進行保存即可.


屏幕截圖
紅旗Linux4.1桌面版上屏幕截圖
要進行屏幕截圖,需要啟動屏幕截圖程序,方法是:
【開始】→【圖像】→【屏幕截圖】
圖5-12 屏幕截圖
屏幕截圖時,首先要選擇抓圖模式.抓圖模式有全屏、游標處的窗口和區域幾種,分別可以截取整個
屏幕、游標所在的窗口以及指定區域的圖像.
其次,可以設置抓圖延時.可以設為無延時,也可以指定延時秒數.
接下來就可以點擊「新建抓圖」開始截圖了.
當設定了延時秒數時,比如5秒,那麼從點擊「新建抓圖」開始算起,5秒后,程序將自動按選定的
抓圖模式進行截圖.這與相機的延時拍照功能是類似的.
共創桌面Linux2005上屏幕截圖
要抓整個屏幕,可以按印屏幕鍵,系統會自動啟動一個抓圖程序,並且已經把全屏幕的
圖像截取到這個程序中,接下來要指定保存位置,保存圖像即可.
要抓取當前窗口,則應按下 組合鍵.
Windows上屏幕截圖
要抓整個屏幕,可以按印屏幕鍵,系統會自動把全屏幕的圖像截取到剪貼板中.接下來
應手動啟動畫圖軟體,進行粘貼,這樣就得到了全屏幕的圖像.
要抓取當前窗口,則應按下 組合鍵.
畫圖
畫圖窗口的組成
圖5-13 畫圖
畫布,各種顏色、形狀的線和面都必須繪在畫布上.有時,畫布比窗口工作區小,這樣就會露出深灰
色的畫板來,畫板只能用於平鋪畫布,本身時不能繪圖的.有的時候畫布比窗口工作區大,這時可以用滾
動條來移動畫布.另外,畫布的尺寸也可以很方便地改變,就像改變窗口尺寸地操作一樣.


工具箱分為兩個部分:工具框和選擇框.工具框中排列著繪圖工具按鈕.選擇框位於工具框的底部,
它的內容隨著工具框的不同而發生變化.啟動畫圖軟體時,工具箱放在畫布的左側,其位置可以被移動.
移動工具箱的方法:把滑鼠指針指導工具箱的頂部,指針變成十字肩頭,此時按下滑鼠,就可以把工具箱
拖放到任意的位置.單擊工具箱中的一個工具圖標,就選擇了相應的工具.當滑鼠移動到畫布上時,滑鼠
指針會變化形狀,表明可以用相應畫圖工具進行畫圖操作.
顏料盒位於畫布的下方,由塗有不同顏色的若干小方格組成.它的左端有兩個部分重疊的小方格,上層方格表示前景色,下層方格表示背景色.滑鼠左鍵單擊某顏色方格,選取的時前景色,滑鼠右鍵單擊某
方格選取的是背景色.繪圖工具在畫布上繪出的色彩就是從顏料盒中選取的.
菜單
【文件】,主要用於文件的打開、保存和列印操作等.還可以把當前畫圖文件設置成牆紙,也可以啟
動郵件程序把當前畫圖文件作為附近郵寄出去.
【編輯】主要用於複製、粘貼等操作,可以新建窗口並粘貼,從文件粘貼,以及複製到文件.
【查看】,用來縮放圖片的顯示.
【圖像】,用於調整圖像大小,對圖像進行翻轉、旋轉等操作.
【設置】,用來控制是否顯示工具欄、狀態欄,切換全屏幕顯示.
繪圖
隨意畫線
有兩種繪圖工具可以用於手工隨意畫線,它們是鋼筆 和刷子 .鋼筆只可能畫出一種粗細的曲
線,這種曲線的寬度是最細的.而刷子可以繪出不同粗細和不同風格的曲線,只要從工具箱的選擇框中選
出所需的刷頭就行了.


畫直線
單擊工具箱中的直線工具 ,然後單擊畫布,得到直線的一個端點,再拖動滑鼠的另一個端點處釋
放,就畫出了一條直線.
如果在拖動滑鼠的同時按住鍵,可以繪製完全水平、垂直的線,以及45度的斜線;如果在拖動
滑鼠的同時按住鍵,可以繪製完全水平、垂直的線,以及30度、60度的斜線.用滑鼠左鍵拖動繪出
的線用的是前景色,而用滑鼠右鍵拖動繪出的線用的是背景色.
如果想繪製某種寬度的直線,那麼從工具箱的選擇框中選取一種直線寬度.要選取直線的顏色,只要
單擊顏料盒的某種顏色即可.這兩個操作都必須再畫直線之前完成.畫其它下也是這樣.
畫折線
單擊折線工具 ,就可在畫布選擇適當的點,連續單擊滑鼠左鍵畫出折線.滑鼠左鍵單擊完折線的
終點后,應點一下滑鼠右鍵表示一條折線畫完了.
和畫直線類似,可以在拖動滑鼠的同時按住鍵,來繪製完全水平、垂直的線,以及45
度和30度、60度的線段.
畫曲線
工具箱中有曲線工具 ,單擊一下就可以開始畫曲線了.
畫曲線有兩種方法.
第一種方法畫出的是閉合曲線.方法是先在畫布選兩個點單擊滑鼠確定第一、第二控制點.這兩個控制點之間的距離將決定曲線的長度,它們之間的連線是曲線在第一控制點處的切線.然後選擇任意地方作
為第三控制點,按下滑鼠進行拖動調整曲線的形狀,在出現希望的形狀時釋放滑鼠,閉合曲線就畫好了.
第三控制點與第一控制點之間的連線卻動了曲線在第一控制點處的另一條切線.兩條切線必然有夾角,因
此閉合曲線是帶尖角的.
第二種方法畫出的是開放的曲線.方法是先按畫直線的方法畫出一條線,接下來選擇任意地方作為第


一控制點按下滑鼠,然後拖動調整曲線形態,再選擇任意地方作為第二控制點,同樣按下滑鼠,調整曲線
形態.經過兩個控制點的調整后,曲線就畫好了.第一控制點與起點相連是曲線在起點處的切線,第二控
制點與終點相連是曲線在終點處的切線.
圓和橢圓
在工具箱中選擇橢圓工具 ,選擇框中就會出現三種不同風格的繪圖模式:第一種是勾畫出邊緣線
條,不填充內部空間;第二種是勾畫出邊緣,用背景色填充內部;第三種是勾畫出邊緣,用前景色填充內
部.單擊其中一項,就會採用相應的繪圖方式.只要對角方向拖動滑鼠,就會畫出橢圓.滑鼠拖動時起始
點和終止點連線的中點就是橢圓的中心,起始點和終止點構成的矩形的長邊和短邊就是橢圓兩軸的長度.
如果只想畫圓,只要在拖動滑鼠時按住鍵就行.
如果在拖動滑鼠時按住鍵,則滑鼠的起始點就是橢圓的中心.
可以同時按下 鍵,則可以拖動滑鼠,畫出正圓,滑鼠拖動時的起始點就是圓心.
矩形和圓角矩形
矩形工具 和圓角矩形工具 的操作方法基本一樣.相應地在選擇框中也會出現三種繪圖模式,與
橢圓工具一樣.
在繪圖區域以對角方式拖動滑鼠,就會畫出矩形或圓角矩形.如果要繪製正方形或圓角正方形,那麼
在拖動滑鼠的同時按住鍵即可.
多邊形
可以用多邊形工具 來繪製多邊形.方法比較簡單,只需選擇合適頂點單擊滑鼠左鍵就可以了.點
擊頂點時,可以適當拖放滑鼠,調整相應頂點的位置.滑鼠左鍵單擊完多邊形的一個頂點后,應點一
下滑鼠右鍵表示多邊形畫完了.


和畫直線類似,可以在拖動滑鼠的同時按住鍵,來繪製完全水平、垂直的邊,以及45
度和30度、60度的斜邊.
編輯色彩
填充工具
在工具箱中單擊填充工具圖標,然後單擊要填充的對象或區域,就可以實現填充操作.單擊滑鼠左鍵,
填充時用的是前景色,單擊滑鼠右鍵,用背景色.
如果要對一個封閉曲線內部進行填充,填充前一定要檢查有無缺口.如果有缺口必須封閉,否則填充
色會漏到曲線外的區域,以至於充滿整個畫布.
噴嘴
噴嘴可以在畫布上噴出不規則分佈的點,顯示出朦朧煙霧般的效果,用它來繪製那些半實半虛的雲彩
或物體的陰影將非常方便.
選取噴嘴后,可以在選擇框中選取一種噴霧模式.噴霧模式決定了噴霧的寬度和密度.
可以單擊畫布某點進行噴霧.也可以在畫布上拖動滑鼠進行噴霧.滑鼠移動得越快,噴霧的密度越稀
薄.
擦子
選取擦子后,可以在選擇框中選取一種形狀的擦子.在畫布上,按下滑鼠左鍵進行拖動,經過的地方
都會被塗上背景色,也就是擦掉畫布上已畫的東西.如果按下右鍵進行拖動,則經過的地方都會被塗上前
景色 ,這在某些時候用起來是比較方便的.
顏色選擇器
有時候,需要使用圖中某一部分的顏色.如果從顏料盒中去找,會比較麻煩.有的時候,該顏色在顏
料盒中是找不到的.遇到這種情況時,應使用顏色選擇器.
單擊工具箱中的顏色選擇器后,單擊要取顏色的那個部位,
定義顏色
可以用滑鼠雙擊顏料盒中的某種顏色,就會彈出選擇顏色的窗口.
圖5-14 選擇顏色
在顏色區域點擊選擇顏色,相應的下面會出現顏色對應的數字.也可以輸入數字定義顏色.


顯示圖片
在繪製圖片時,往往要根據需要對圖片進行放大和縮小.比如要修改圖片的某個細節,就有必要進行
放大.
縮放
在查看縮放菜單下列出了各種百分比,點擊相應條目,就可以按指定的百分比查看圖片了.
點擊放大、縮小,同樣可以實現圖片的縮放.
上述操作都在主工具欄上有相應的快捷方式圖標,可以直接點擊使用,比較方便.
縮略圖窗口
可以通過【查看】→【顯示縮略圖】打開或關閉縮略圖窗口.
縮略圖窗口沒有菜單條,只有標題欄和畫布.用戶可以改變該窗口的尺寸,程序會自動隨窗口的大小
調節其中圖片的顯示比例,保證既可以看到圖片的全貌,又充滿整個窗口.
顯示網格
當圖片的顯示比例被放大至600%以上時,【查看】菜單中的【顯示網格】就可以用了.在放大后的圖
片上加上網格,可以讓用戶精確定位.
擴大顯示區域
對於較大的圖片,用戶總希望能看到它們的全貌.可以採取下列措施擴大顯示區域.
* 使窗口最大化;
* 拖動工具箱顏料盒使其成為浮動窗口;
* 通過【設置】菜單,取消工具欄和狀態欄的顯示;
* 通過【設置】菜單,進入全屏模式.
編輯文字
如果要在畫圖時輸入文本,可以利用文本輸入工具.單擊文本工具,在畫布上對角拖動滑鼠就會出現
一個文本框,此時就能輸入文字了.
如果要改變字體及其大小,可以使用文本工具欄.默認情況下,單擊文本工具后,文本工具欄就會自
動顯示出來.如果沒有,可以點擊菜單【設置】→【工具欄】→【顯示工具欄】,使之顯示出來.
編輯圖片
圖片的基本操作有剪切、複製、刪除、粘貼以及撤銷和重複等,這些操作與在「文本編輯器」中的文


本編輯操作大同小異,因而就不再贅述了.下面介紹對於圖片特有的編輯操作.這些操作都可以通過菜單
【圖像】來實現.當選定圖片的某個區域時,【圖像】的菜單名稱會變成【選擇區】,此時的操作,只對
選定的區域有效.
自動裁剪
如果想把整個圖片邊緣的空白區域全部剪除,可以執行【圖像】→【自動裁剪】的功能.
如果想把圖片的某個局部留下,其餘部分都剪除,則可以先把要保留的區域選中,軟后執行【選擇區】
→【設置為圖片(裁剪)】的功能.
調整大小
可以對整幅圖片或者選定的區域調整大小.執行【圖像/選擇區】→【調整大小/縮放】就會出現如圖的
窗口.利用該窗口,可以指定圖片長寬,或者指定縮放比例.如果要保持長寬的比例,應該把「保持縱橫
比」勾選上.翻轉、旋轉、扭曲
有時,需要把圖片或圖片的一部分上下顛倒,或者左右顛倒.要實現這種操作,執行【圖像/選擇區】
→【翻轉】操作就可以.如果是要上下顛倒,應該在彈出的方向選擇窗口中選擇「垂直(上下翻轉)」;如
果要左右顛倒,則應選擇「水平」方向進行翻轉.
有時,需要把圖片或圖片的一部分一定角度進行旋轉.要實現這種操作,執行【圖像/選擇區】→【旋
轉】操作,在彈出的窗口中指定旋轉角度就可以.
如果把圖片或圖片的一部分一定角度進行傾斜扭曲,可以執行【圖像/選擇區】→【偏斜】操作,可以
在彈出的窗口中指定傾斜方向和角度.
綜合使用翻轉、旋轉、扭曲等操作,可以繪製出任意角度的圖形.
反色、單色、灰度
反色是指將圖像中的顏色變為其互補色.比如,白色(顏色代碼為#FFFFFF)的互補色是黑(顏色代碼為


#000000),紅色(顏色代碼為#FF0000)的互補色是青(顏色代碼為#00FFFF).從計算機底層的運算上看,把一
個顏色的代碼取反,就得到該顏色的互補色的代碼.
單色,是把圖像轉換成只用黑白兩種顏色.
灰度,是把圖像按顏色的亮度不同,變換有灰度層次的黑白圖像.
上述顏色變換都可以通過【圖像/選擇區】菜單實現.
圖形文件
畫圖默認以PNG格式保存圖片.同時該軟體還支持多種其他類型的圖形文件格式,例如:BMP,JPEG
等.


[火星人 ] 《redflag-Linux4.1操作系統初級教程》(5)郭守華 宋雪嬌已經有502次圍觀

http://coctec.com/docs/linux/show-post-57456.html