歡迎您光臨本站 註冊首頁

精通 Eclipse V3.4,第 1 部分: Eclipse 工作台

←手機掃碼閱讀     火星人 @ 2014-03-12 , reply:0
  
“精通 Eclipse” 這一系列文章將向 Eclipse 新手講授 Eclipse IDE 的詳細內容。在學完本系列后,您將成長為一名高級用戶。在第 1 部分中,您將了解 Eclipse IDE 的各個部分及如何自定義這些部分。

第 1 部分適用於 Eclipse 的新用戶,將向 Eclipse 新手解釋一些通常很難理解的 Eclipse 術語,並介紹 Eclipse IDE 的各個部分。本文將說明 Eclipse 工作台是什麼;並探究項目與工作空間(Eclipse 組織源代碼的方法)之間的差別及其之間的關係。最後,本文將說明如何根據需要自定義 IDE 的各個部分。

工作台

主 Eclipse 窗口稱為工作台(參見圖 1)。它包含菜單欄、工具欄、編輯器和視圖等內容。工具欄下方放置編輯器和其他視圖的區域稱為工作台頁面。此頁面包含界面的大部分可見部分:編輯器和視圖。


圖 1. Eclipse 工作台


編輯器

編輯器 是您在 Eclipse 進行開發活動的主要內容區域。注意,術語 “編輯器” 不一定表示文本編輯器;甚至 WYSIWYG 表單設計器都可以視為編輯器。帶有工具欄和視圖的 Eclipse 工作台可能會變得十分擁擠,因此如果編輯器需要更多空間,請單擊位於右上角的 Maximize 按鈕。這樣做將隱藏所有其他視圖,從而給編輯器提供更多屏幕空間。您可以通過單擊 Restore 恢復所有視圖。

有時需要一次查看多個編輯器窗口,可能需要將某些內容從一個編輯器窗口複製並粘貼到另一個編輯器窗口,或者需要在一個編輯器窗口中鍵入內容時閱讀另一個編輯器窗口中的信息。為了幫助實現這項功能,Eclipse 允許您並排或層疊堆放編輯器窗口。為此,需要把打開的編輯器窗口的選項卡拖到某一側或者頂部/底部;它將堆疊在某一側,允許您輕鬆地使用打開的編輯器。

如果打開了許多編輯器窗口,通過手動掃描並單擊多行選項卡來切換到所需選項卡會十分耗費時間。Eclipse 提供了一個方便使用的快捷鍵可以簡化此操作:按 Ctrl+E 組合鍵,然後將在選項卡行中的右上角顯示彈出式菜單並列出所有打開的編輯器(參見圖 2)。您可以選擇一個或者開始鍵入需要打開的編輯器名稱,然後列表將開始篩選。


圖 2. 按 Ctrl+E 組合鍵將顯示允許在編輯器窗口之間輕鬆切換的彈出式菜單


視圖

視圖 是停靠在編輯器某一側的小窗口,其中包含關於編輯器內容的更多信息。通過單擊右上角的 Minimize 按鈕將視圖最小化;該視圖將最小化到窗口一側的快捷鍵欄中(參見圖 3)。單擊快捷鍵欄中的視圖按鈕將臨時彈出視圖。這是節省屏幕空間同時仍然可以輕鬆訪問視圖的好方法。


圖 3. 快捷鍵欄允許將視圖最小化同時仍然提供訪問


可以將視圖與其位置分離。要分離視圖,請將其拖到工作台窗口外部,或者右鍵單擊其選項卡並選擇 Detach。分離后的視圖將像一個新窗口一樣運行並且顯示在工作台窗口的頂部。視圖還可以停靠在工作台窗口的不同側面。為此,請拖動視圖的選項卡,並將其放到想要停靠的一邊。要打開視圖,請選擇 Window > Show View。將會彈出一個顯示一些可用視圖的菜單。如果需要的視圖並未列出,請單擊菜單底部的 Other。將會彈出一個顯示按類別組織所有視圖的對話框。您可以在頂部文本框中輸入需要打開的視圖名稱以篩選視圖列表。此外,要更加輕鬆地打開此對話框,請單擊工作台窗口左下角帶有 + 號的圖標,從而打開與選擇 Window > Show View 得到的相同的菜單。





比較項目與工作空間

Eclipse 將通過項目和工作空間的概念組織源代碼。工作空間 是項目的集合。項目 是源代碼文件的集合。通常,工作空間和項目的概念在新手中造成了很多混淆之處,因為 Eclipse 中項目的定義不同於其他 IDE 中的項目。

將項目視為獨立模塊而將工作空間視為項目,這是從軟體開發的角度來考慮這些概念的好方法。因此,您擁有包含多個模塊(Eclipse 術語中的項目)的一個項目(Eclipse 術語中的工作空間)。下面幾個小節將詳細討論各個概念。

工作空間

工作空間 包含所有項目和設置,例如用於語法高亮顯示的顏色、字體大小等。您無法在 Eclipse 的工作空間外部工作。在首次啟動 Eclipse 時,它將提示設置工作空間的默認位置。通過選擇 File > Switch Workspace > Other,可以隨時創建新工作空間或切換到其他工作空間。在打開的對話框中,可以鍵入已有工作空間的位置或者鍵入其他位置以在其中創建新工作空間。該對話框還提供將設置複製到新工作空間中的選項。但是,這種說法並不正確,因為該選項只複製窗口布局和工作集,而不複製語法高亮顯示的顏色、字體大小模板等內容。您可能希望把所有這些設置都複製到新工作空間中,因為重新配置已經在現有工作空間中配置過的許多設置會十分痛苦。幸運的是,Eclipse 提供了一種將所有設置複製到新工作空間中的簡單方法:

  1. 選擇 File > Export。
  2. 在打開的對話框中,選擇 General > Preferences,然後單擊 Next。
  3. 選擇 Export All,提供圖 4 中所示文件的路徑,然後單擊 Finish。工作空間的所有設置都將被保存到指定文件中。
  4. 切換到新工作空間,選擇 File > Import,然後選擇 General > Preferences。
  5. 指向剛剛保存了設置的文件並單擊 Finish。您的設置將被導入到新工作空間中。

圖 4. 創建或切換工作空間


位於工作空間目錄中的 .metadata 目錄包含 Eclipse 內的各個插件存儲的所有設置。此目錄的存在將告訴 Eclipse 當前目錄是有效的工作空間。.metadata 目錄還包含以 .log 命名的文件。此文件將包含在運行 Eclipse 時可能拋出的所有錯誤或異常。如果 Eclipse 在某一刻意外崩潰,該文件將對錯誤診斷十分有用。

項目

Eclipse 術語中的項目可以是獨立的應用程序或模塊,這取決於選擇如何組織工作空間。要創建一個新的 Java™ 項目,請選擇 File > New > Project。在打開的對話框中,選擇 Java > Java Project。

許多新手都會被位於此對話框中的 Project name 文本框搞糊塗(參見圖 5)。您將使用此框篩選不同類型項目的列表,而非命名項目。從樹中選擇 Java Project 項並單擊 Next 以進入嚮導中的下一步。在這裡,您可以命名項目並配置其設置。


圖 5. 創建 Java 項目


位於 Create Java Project 對話框中央的 JRE 組將允許選擇用於構建此項目的 Java 版本。Project Layout 組將表示是需要將源代碼文件和生成的類文件都放在一個文件夾中,還是需要將其分別放在獨立的文件夾中。建議保留默認設置:Create separate folders for sources and class files。這樣可以很好地把代碼與生成的二進位文件分開。單擊 Finish,然後將在工作空間目錄中創建與項目同名的新文件夾。項目文件夾包含兩個分別用於保存源代碼文件和類文件的名為 src 和 bin 的文件夾。您將專門在 src 文件夾中工作;Eclipse 將管理 bin 文件夾以在後台自動生成類文件。





自定義工具欄和菜單

您可以根據需要自定義位於 Eclipse 窗口頂部的工具欄和菜單欄。工具欄和菜單欄都是基於透視圖配置的。透視圖 是 Eclipse 根據您要執行的特定任務分組各個視圖、工具欄和菜單布局的方法。例如,在默認情況下,Eclipse 擁有名為 Java 和 Debug 的透視圖,它們分別用於開發 Java 代碼和進行調試。Debug 透視圖擁有專門在調試時使用的視圖和工具欄按鈕;Java 透視圖沒有這些。通過選擇 Window > Open Perspective > Other 或單擊工具欄最右側按鈕可以切換透視圖。


圖 6. 使用位於工具欄右側的按鈕可以切換透視圖


要自定義透視圖的工具欄和菜單,請右鍵單擊頂部的主工具欄並選擇 Customize Perspective,然後單擊 Commands 選項卡。在這裡,各個菜單/工具欄項都是按功能分組的,如圖 7 所示。例如,可以選擇 Search 列表項以啟用與搜索相關的菜單和工具欄項(Eclipse 把工具欄和菜單項稱為命令,就如向 IDE 發出的命令一樣;因而,選項卡的標籤為 Commands,並且可以啟用/禁用命令組)。


圖 7. 自定義工具欄和菜單欄項






自定義 Eclipse 首選項

Eclipse 是一個擁有許多插件的大型複雜 IDE,並且它提供了大量可以自定義的選項。幸運的是,可以在一個集中位置找到所有這些內容。選擇 Window > Preferences 以打開 Preferences 對話框。


圖 8. Preferences 對話框


該對話框包含??個很大的可自定義選項樹。有時,可能很難記住需要更改的設置所在的確切位置。幸運的是,您可以在頂部的文本欄位中鍵入以篩選龐大的選項樹。例如,在框中鍵入 fonts 將立即篩選該樹以僅顯示與字體相關的項。下一節將介紹如何更改一些常見設置。

更改字體

選擇 General > Appearance > Colors and Fonts(參見圖 9)。在這裡,您可以更改 Eclipse UI 的各個部分的字體。例如,要更改 Java 編輯器的字體,請執行以下操作:

  1. 在 Preferences 對話框中,選擇 Java > Java Editor Text Font。
  2. 單擊 Change。
  3. 選擇所需的字體和大小。
  4. 單擊 Apply。

圖 9. 更改字體


更改鍵盤快捷鍵

在 Preferences 對話框中選擇 General > Keys(參見圖 10)。在這裡,您可以設置/更改每條 Eclipse 命令的鍵盤快捷鍵。例如,要更改 Step Over 命令的快捷鍵,請執行以下操作:

  1. 在文本欄位中鍵入 Step Over。
  2. 在現在經過篩選后的列表中選擇 Step Over 命令。
  3. 在 Binding 框中,按下新鍵盤快捷鍵。注意不必鍵入快捷鍵 — 只需按下按鍵。例如,要把 F2 鍵分配給命令,請按 F2 鍵。
  4. 如果新快捷鍵與任何現有鍵盤快捷鍵發生衝突,則會顯示在 Conflicts 列表中。
  5. 更改完快捷鍵后,單擊 OK。

圖 10. 更改鍵盤快捷鍵






結束語

您已經詳細地查看了 Eclipse IDE 的各個部分。現在已經了解了 Eclipse 工作台及其組成部分是什麼。了解了工作空間和項目是什麼、兩者的差別及兩者之間的關係。您還知道如何根據需要自定義 IDE 的各個部分及如何將這些設置從一個工作空間導出到另一個工作空間。第 2 部分將說明如何使用 Java 項目和 Eclipse Java 開發環境(JDT)。(責任編輯:A6)



[火星人 ] 精通 Eclipse V3.4,第 1 部分: Eclipse 工作台已經有447次圍觀

http://coctec.com/docs/linux/show-post-69024.html